Opigno LMS User manual


Upgrade from opigno_lms <= 3.0.3

Before upgrading from opigno_lms <= 3.0.3 or the legacy version ensure that the following instruction was done https://opigno.atlassian.net/wiki/spaces/OUM3/pages/2871263233

In case the warning appears:

The installed version of the /Opigno LMS/ module is too old to update. Update to an intermediate version first (last removed version: 9015, installed version: 8005).

you need to apply the opigno_lms_update_9015 update which was removed in opigno_lms 3.0.4 version.

  1. composer require opigno/opigno_lms:3.0.3 - pin a specific version of opigno_lms

  2. drush updb -y - ensure that all updates are applied.

  3. composer require opigno/opigno_lms:^3.0 - set a requirements to ^3.0 or ~3.0.9 (as you preferred 3.0.9 is the latest on this moment)

  4. drush updb -y - check that all remaining updates are applied or the database is up to date

Upgrade from opigno_lms > 3.0.3

Update your https://bitbucket.org/opigno/opigno-composer/src/3.0.3/composer.json according to the recommended version.

minimum requirement may looks like:

"require": { "wikimedia/composer-merge-plugin": "2.0", "composer/installers": "*", "cweagans/composer-patches": "^1.7", "drupal/core-composer-scaffold": "^9.4.0", "opigno/opigno_lms": "~3.0.9" },

run composer update opigno/opigno_lms -W

see the related topics:


Copyright 2021 Connect-i. All Rights Reserved - https://www.opigno.org